Sunday, September 16, 2012

How to solve: Skype displaying Japanese characters as boxes

Problem with Skype not displaying Japanese/Chinese/Korean characters? Here is the solution that worked for me.


Today, when I started Skype, I had something strange happened. The name of the contacts in Japanese were replaced by squares, ie Skype was not displaying Japanese correctly anymore. I could still type some Japanese text in the message but the name of the contacts were not supported. The menu was gone too (choice between square-square-squre and square-square-square).

The problem was only with Skype, the rest of the computer was working fine: notepad, the name of the directories and folders were fine etc...

I tried to reinstall Skype: did not help. I tried to Google the answer: did not help. Most websites would simply ask you to use another font (under settings, IM and SMS etc... and change from Tahoma to Arial Unicode MS) or to change the settings of your new PC). I still could not read Japanese characters! Just a bunch of boxes/Squares or whatever you want to call them.

Incredible test

I logged off the user I was using, logged on with the admin user and ... Skype was working! Completely fine, with Tahoma (?!!) and with the global settings of the computer set to Norway/Norwegian. How come. I logged again to the user that had the problem: it was still failing. So the problem was only happening for 1 user. It does make sense as many websites were saying that they had problems with some users only or some PC only.

Step-by-step solution

Update 16 October 2012: I have had the problem again and wrote a new post about it. Check it here:
http://smallittips.blogspot.com/2012/10/problem-with-asian-characters-in-skype.html

Of course, I was still not happy, as I wanted to use Skype for both users (admin and the one failing), so here is what I did:
  1. logged in with the failing user
  2. closed every program including Skype
  3. logged off this user (not just switch user, completely log off)
  4. logged in as admin
  5. opened a directory and went to C:\Users\failing-user
  6. added \AppData at the end of the address: C:\Users\failing-user\AppData
  7. deleted everything in
    • C:\Users\failing-user\AppData\Local\Temp (mind the "Local")
    • C:\Users\failing-user\AppData\Local\Microsoft\Internet Explorer (Skype uses Internet Explorer)
    • C:\Users\failing-user\AppData\Local\Microsoft\Windows\Temporary Internet Files (you have to type this one too)
    • C:\Users\failing-user\AppData\Local\Microsoft\Windows\Explorer
    • C:\Users\failing-user\AppData\LocalLow\Microsoft\Internet Explorer (mind the LocalLow instead of Local)
  8. logged again as the failing user
  9. it was working
I really hope this will also solve the problem you have with Skype not displaying Asian characters properly (only squares/boxes).

1000 thanks to Servermin for a post he wrote about Chinese characters not being displayed by Skype (had a hard time finding it but it was mostly the solution I described here).

10 comments:

  1. Thanks for putting this on the Net!
    It is a life saver!

    ReplyDelete
    Replies
    1. Thank you for commenting! It is so nice to get feedback from readers!

      Delete
  2. Does this work w/ Skype 6.0?
    I uninstalled my language pack early last morning and re-installed them (French, Korean, Japanese, Korean, English, Swedish) and Skype worked them out just fine.
    I shut down late last night and this morning went to re-boot Skype.
    It then displayed them as boxes.
    I can c/p the Korean/Japanese characters just fine and seem them fine in my im box, but when they go into chat.
    They turn to boxes.
    My nickname also is now bunch of boxes.
    :(

    ReplyDelete
    Replies
    1. Yes, you should definitively then try this.

      Delete
  3. I use windows 8 with only one account and it says I am the admin. But I don't have a C:\Users\failing-user directory?

    ReplyDelete
    Replies
    1. I am sorry, I don't know the directory structure for Windows 8.

      Delete
  4. I am also the admin and I don't have a Users folder :(

    ReplyDelete
    Replies
    1. Are you on Windows 8? Is there any temporary files linked to internet explorer you could remove?

      Delete
  5. Good tips to solve this problem of Mozilla is not opening...greatly appreciated!!
    Skype Technical Help please visit the link.

    Thankyou
    Lacy Brown

    ReplyDelete
  6. those are really great tips and it has solved my problem. I used to learn japanese for skype at http://preply.com/en/japanese-by-skype and it was causing me delays before but thanks to this, I have solved it. thanks a lot.

    ReplyDelete